Website unavailable

Incident Report for Siit Status

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 20:02 UTC

Monitoring

A fix was implemented by the provider and is propagating
Posted Jun 03, 2025 - 17:58 UTC

Identified

An issue is affecting our website provider (www.siit.io). Our app is still accessible using the following link: https://app.siit.io
Posted Jun 03, 2025 - 16:14 UTC